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© Introduction

3D presentations are a powerful way to
communicate complex designs and
ideas, especially in industries like
manufacturing, architecture, and
engineering. We call them “Jigs”. For
SolidWorks users, creating optimized
models for platforms like JigSpace
ensures that these presentations run
smoothly and look their best.

This guide is designed to help you
prepare and optimize your CAD models
for importing to JigSpace, covering
detailed steps on simplifying models and
exporting them efficiently. By following
these steps, you'll reduce the complexity
of your models without sacrificing
quality, leading to better performance
and ease of use in JigSpace.

Who should use this

This guide is aimed at SolidWorks users
who frequently work with complex
assemblies and want to streamline their
workflow for creating Jigs, or preparing
assets for a team using JigSpace. This
guide will help you utilize your existing
CAD assets to generate more efficient,
optimized 3D models with smaller
number of meshes and less polygons
after they are imported to JigSpace.

The methods described here are
particularly useful for those working
with large assemblies or parts that need
to maintain performance without

compromising visual integrity.

‘ ‘ “We’ve seen

significant
improvements in the
performance of our
Jigs by using the
simplify tool within
SolidWorks.

It has allowed us to
export optimised 3D
data while maintaining
the integrity and
structure of the
engineering data.”

Craig Hooper

Mechanical Engineer and General
Manager

DTCo
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© Export formats

J9

For best results, we recommend you export all SolidWorks
assemblies or parts as STEP files for importing into Jig. However,
a range of CAD file formats, including native .sldasm and .sldprt
files are also supported for upload to your Jigs.

Settings for exporting large assemblies

One way to improve performance of large assemblies - typically
made up of several sub-assemblies and potentially hundreds of
parts - is o ensure that one STEP file is exported for each

assembly or sub-assembly, instead of one very large file.

You can enable this setting for all future STEP exports by following
these steps :

e Tools > Options > System Options > Export > STEP,
 Select Export assembly components as separate STEP files
(recommended for large assemblies).

This option exports assemblies as atomic STEP files.
Separate STEP files get created for each component in the

assembly.

STEP files have a 3 main configurations. We recommend
exporting to type STEP AP203 which generally creates the
smallest number of objects in your Jig (and thus your
performance). If you wish to export colors as part of your
assembly files then we recommend STEP AP214.

System Options - STEP
System Options
General File Format:
MBD STEP v
Drawings Output 33
Display Style
Ares Hatch/Fill @) solid/Surface geometry
Performance O wiretrame
Colors Export sketch entities
Sketch
Relations/Snaps Set STEP configunation data
Display
ort face/edge properties
= Mes edge p
B s ) &xport appearances
Assemblies [Jexport 30 Curve features
External References Split periodic faces
Oefauk Templates Cl&xport assemb a5 separate STEP files
File Locations Ir for large blies)
FeatureManager
Spin Box Increments
View
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O CAD data imported

D Share of uploads

: 3
CAD file mesh Scale Color Labels
Share by CAD file extension in 2023

fox @ @ @

.stl

gltf / glb © © © ©
obj © © © i
step © © © 0
s ©@ O po %
sldasm/.sldprt @ @ © 9 @© ©
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O Simplify tool

Step by step instructions to simplify your assembly

We recommend using the SolidWorks Simplify tool to reduce the amount of geometry to only what is needed before importing into JigSpace.

P ) . - . =
DS SOLIDWORKS File Edit View Insert Tools Window ‘@ D b &‘7 4 > g > = L} = {e} 32 7 Search Commands D @ @ — F = X
1] = = = o 2 s | e 3
S BE B & ® @ ‘@ B ¢ N 9 @ g
Insert Mate Linear Component ~ Smart Move Show Assembly Reference New Bill of  Exploded Instant3D Update Take Large
Components Pattern Fasteners Component Hidden Features Geometry Motion Materials — View SpeedPak  Snapshot [Assembly
< 5 Components < Study Subassemblies Settings A

Assembly ‘ Layout ‘ Sketch ‘ Markup ‘ Evaluate ‘ SOLIDWORKS Add-Ins ‘

PLERPH OO QR - 00 - & x|

®E[R¢[@)
-
89 7 DOF Serial Robotic Arm (Def
» History
Sensors

» Annotations

LJ Front Plane

Ij Top Plane

LJ Right Plane

I_, Origin B
@ (-) Assem1<1> (L‘&fauI«D{
‘@ (-) Beicep<1> (Default<Dis,
@ i\\ (-) Forearm<1> (Defau

@@ Mates

v v v v

L

efeETes)

W11 Model [ Motion Study 1

SOLIDWORKS Professional 2021 SP4.1

w sL-NzZ
Live

J9

MMGS - &
4:03PM ﬁ

26/09/2024 e

Under Defined Large Assembly Settings Editing Assembly a

*TLEETORELDOR

B Q Search
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1. In the Solidworks GA (general assembly): 2. Click in the top menu:
» open each sub-assembly or group of parts that move together » Tools > Find/Modify > Simplify
by right clicking
e open sub-assembly

Assemb'y ’ Layout ‘ Sketch ’ Markup ‘ Evaluate ‘ SOLIDWOR D;'SSOLIDWORKS File Edit View Insert.Tools Window ﬁ D 2 @ 2 24 Q b ¥ '&l' '

S = @ v ¥ B

Insert Mate Linea SOLIDWORKS Applications » |Assembly Reference New  Bill of

r |7 //1? Components Features Geometry Motion Materials
[:[Jl“" |\|\:)) /K ( ‘\) ) Xpress Products ’ . . Study
— Nt
@ §: E '@ O > -+ — Assembly ‘ Layout ] Sketch ‘ Markup | Evaluate %‘ Asset Publisher... 39 f) gg @] @ v @
.[\[I:I \: l.{ D:'I 8 Envelope Publisher...
?v UV £ @ B & & > Magnetic Mate ON/OFF
-

$o  Defeature...

< z A\ 7 DOF Serial Robotic Arm
i@ 7 DOF Serial Robotic Arm (Def @Histewb ‘ % Eport o ALC..

. T X Sensors Select
’ HIStOf'y » Annotations .

@ Magnified Selection

i) m Front Plane ox Selection
- Sensors ) Top Plane ‘.B i

Lasso Selection
Ijl Right Plane 9

== o @ B‘ Select over Geometry
» Annotations L, orin ,
% » @ A\ (+) Assem1<1> (Defa Niy Select Al Ctrl+A
-1] » @ /I\ e 4
' £\ (+) Beicep<1> (Default
L. FI’OI’It Plane » @ (-) Forearm<1> (Default) G
»
s @@ A Vates ompare
l @ % % [ Find/modity 3
= | Design Checker > O‘-'D Simplify...
f Format Painter... -
Customize Menu
Component Selection 4
Gomponent ’ ‘
' I ! Sketch Entities ¢
‘ Sketch Tools »
» FEIE0T0] Model [ MotionStudy1 | |
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3. Simplify the sub-assembly
a. Choose certain features to simplify,

« Or alternatively the entire sub-assembly (recommended), and
specify the simplification factor (from O-1)

« It is good to start with O.1, and then increase/decrease the value

depending on the results

Features: | All, Fillets, Chamfers, Holes, Extrudes, Revolves N
v Al

Simpliﬁcatly Fillets I
’7 Chamfers
l7 Holes

rarameerTasey

0O Ignore features affecting
assembly mates

Find Now Stop

#; Results

J9

b. Feature parameter vs volume based
» Volume based is recommended as it will identify small parts
without compromising the main features of the model. Generally it

will also decimate the model more than feature based

» Depending on your model it is good to try both methods to see

which one works better for your use case

G

Features: l All, Fillets, Chamfers, Holes, Extrudes, Revolves v
Slmpliﬁation factor: 0.100000 i_‘__ﬂ
LY}
Feature o Volume
Parameter Based
0 Ignore features affecting
assembly mates
Find Now Stop

&) Boss-Extrude4@Forearm-1/Hand-2/GT2 20T 5D-2

@ Cut-Extrude1@Forearm-1/Hand-2/GT2 20T 5D-2

—@ Cut-Extrude1@Forearm-1/Hand-2/D3mm L10mm Allen Bolt-2
—@ Cut-Extrude1@Forearm-1/Hand-2/3mm Hex Nut-33

@ Cut-Extrude1@Forearm-1/Hand-2/3mm Hex Nut-26

@ Cut-Extrude1@Forearm-1/Hand-2/3mm Hex Nut-31

Cut-Extrude 1 @Forearm-1/Hand-2/D3mm L15mm Allen Bolt-8

& Cut-Ftrude1@Forearm-1/Hand-2/MN3mm | 1Smm Allen Ralt-11
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c. Ignore features affecting assembly mates tickbox

« Ticking this box will simplify the model more, however as it states -

assembly mates will be broken

o To be safe, it is best to leave this box unticked

Features: | All, Fillets, Chamfers, Holes, Extrudes, Revolves v ‘
Simplification factor: 0.100000 E‘
O Feature o Volume
Parameter Based

0 Ignore features affecting
assembly mates

Find Now Stop

#5 Results

J9

d. Once the features have been identified scroll down > tick ‘all’ >

click ‘suppress’

« Simpli o3 x
®@ x

B L e ]

(@ Cut-Extrude5@Upper Carrier-1
vvvvv [@ Cut-Extrude6@Upper Carrier-1
----- [@ Cut-Extrude7@Upper Carrier-1
--[@ Cut-Extrude8@Upper Carrier-1
(@ Cut-Extrude1@Planet Gear 60T-1
----- [@ Cut-Extrude2@Planet Gear 60T-1
~[@ Cut-Extrude4@Planet Gear 60T-1
(@ Cut-Extrude1@Ring Gear 180T-1
(@ Cut-Extrude2@Ring Gear 180T-1
----- [@ Cut-Extrude3@Ring Gear 180T-1
-[@ Cut-Extrude4@Ring Gear 180T-1
--[@ Cut-Extrude5@Ring Gear 180T-1
(@ Cut-Extrude6@Ring Gear 180T-1

235 feature(s) found.

Suppress

(] Unsuppress child features

(] create derived configurations
Narme  Simplify_1

Configurations
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4. File > Save as > Save as type > SolidWorks Part

a. Save your first simplified sub-assembly to a new folder. You will need to repeat this for other parts of your assembly.

5 SOLIDWORKS |File |Edit View Insert Tools Window # A [ - -8 - & - - E 8 §8% « 7. B Search Commands Q- ® ® _ @ I

o~ = [0 % @ iy .
B ® @ @ ¥ B & [ 8 @ N9
Insert D New... Ctrl+N e Show Assembly Reference New Billof  Exploded Instant3D Update Take Large
Components| @ o Ctrl nent Hidden Features Geometry Motion Materials  View SpeedPak  Snapshot |Assembly
5 DEN... 0 Components = s Study - Subassemblies Settings
Open Recent v P = S =
{ @ O) < ] = e o = = I | Hagl N
sembly | Layout Ske‘ E e PP Ry T @ U -|® % & 03 =
= %) Close Ctrl+W r
b [EIET| & [
’ =) . [
" _@ Make Drawing from Assembly
A&\ 7 DOF Serial Ro 9 Make Assembly from Assembly @ save As X
History
- & s Ctrl+S
Sensors e d &« v & > ThisPC > Google Drive (G:) v C Search Google Drive (G:) Pl
[/ Annotations @ Save As...
Front Plane [ save A Organise v New folder = - (3]
Top PI <«
ROPht :Ine Page Setups . Work Name Date modified Type
ight Plane
I—» Origin @ Print Preview... Office Artwork My Drive /2024 8:20 AM File folder
@ Assem1<1> (Def g Print... Ctrl+P Other computers File folder
B | .
@B A\ seicep<> (t[d] Print3D.. = Shared drives 23/00/2024 8:20 AM File folder
/l\»\ (-) Forearm<| _, v This PC
@ e Z@ publish to eDrawings i
@@ Mates > = Local Disk (C:)
B Pack and Go... .
> & Google Drive (G:)
Send To...
> ¥ Network
Reload...
x
& Replace...
Find References... File name: ‘ 7 DOF Serial Robotic Arm bod ‘
l Save as type: SOLIDWORKS Assembly (*.asm;".sldasm) ¥ I
Rigpeities:. Description: Add a description
000 Model [}«
linder Nafined 1arne Accem @) Save as [l Include all referenced components
(O) Save as copy and continue Add prefix
Advanced
(0) Save as copy and open Add suffix

~ Hide Folders Save Cancel
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4. File > Save as > Save as type > SolidWorks Part

J9

b. Ensure you have selected SolidWorks Part (.sldprt)

c. Geometry to save > Exterior faces > Preserve geometry references > Save

Organise v

- Work

£l ~>mt)
3D XML For Player (*.3dxml)
T ACIS (*.sat)
Additive Manufacturing File (*.amf)
Adobe Illustrator Files (*.ai)
Nel Adobe Photoshop Files (*.psd)
Adobe Portable Document Format (*.pdf)
Assembly Templates (*.asmdot)
CATIA Graphics (*.cgr)

Office Artwor eDrawings (*.easm)

v M This PC

> ‘== Local Disk (!

> & Google Driv

> ‘; Network

HCG (*.hcg)

HOOPS HSF (*.hsf)

IFC 2x3 (".ifc)

IFC 4 (*.ifc)

IGES (*.igs)

JPEG (*jpg)

Microsoft XAML (*.xaml)
Parasolid (*x_t;*x_b)
Polygon File Format (*.ply)
Portable Network Graphics (*.png)
ProE/Creo Assembly (*.asm)
STEP AP203 (*.step;*.stp)
STEP AP214 (* step;™.stp)
STL (*.stl)

Tif (*.tif)

File name: VRML (*wrl)
Save as type: | SOLIDWORKS Assembly (*.asm;™.sldasm)

Description: Add a description

O sSaveas (") Include all referenced components
(O) Save as copy and continue Add prefix

() Save as copy and open Add suffix

A Hide Folders

Advanced

Cancel

% Save As
« > v~ 4 & > ThisPC > Google Drive (G:)
Organise v New folder
7 DOF Robotic Arm Name
@ new method My Drive
process2 Other computers
Shared drives
process 1
v Il ThisPC

> & Local Disk (C:)
> & Google Drive (G:)

> U Network

Search Google Drive (G:) yel

(1]
4

Type
File folder
File folder

File folder

File name: | 7 DOF Serial Robotic Arm

Save as type: SOLIDWORKS Part (*.prt;*.sldprt)

Description: Add a description

Geometry to save: () All components

(O Include specified
components

Override defaults

@ Preserve geometry
references

~ Hide Folders

Cancel
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5. Repeat steps 1-4 on the remaining sub-assemblies

6. Create a new Solidworks assembly file

New SOLIDWORKS Document

Part Assembly Drawing
a 3D representation of a single design component  a 3D arrangement of parts and/or other assemblies a 2D engineering drawing, typically of a part or
assembly
Advanced Cancel Help

7. Import all simplified sub-assembly parts from steps 1-4

8. Reconstruct the General Assembly (GA) model

J9

9. Save the general assembly file as a SolidWorks assembly or a

STEP AP214 format, make sure to rename it as the simplified

model to avoid confusion.

B Save A
& > v A & > ThisPC > Google Drive (G:) v C Search Google Drive (G:) Pl
Organise v New folder = - (2]
process 2 Name - Date modified Type
process 1 ~ My Drive 25/09/2024 1:07 PM File folder
- Other computers 25/09/2024 1:07 PM File folder
~ Shared drives 25/09/2024 1:07 PM File folder
v [l ThisPC

> = Local Disk (C:)
> & Google Drive (G:)

> 3 Network

File name: ] 7 DOF Robotic Arm Simgliﬁed Assembu

Save astype: SOLIDWORKS Assembly (*.asm;*.sldasm)

Description: Add a description

°Save as Include all referenced components
() Save as copy and continue Add prefix
() Save as copy and open Add suffix

A Hide Folders

Advanced

Cancel

10. Import the simplified .sldasm assembly file or STEP file into

JigSpace to begin making your 3D presentation or augmented

reality experience.
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O Quick simplify alternative

This method is recommended for simple assemblies. Example of simple assembly after importing into JigSpace

It is the quickest and easiest in terms of steps to export the ece

model from SolidWorks, however it will not be as flexible to @ Objecklt a

v @ Piston.sldz

2%

work with once imported in JigSpace.

@ Object4_Mesh4

@ Object3_Mesh3

1. In the SolidWorks GA, Tools > Find/Modify > Simplify + Z:"‘T::
. ,

2. Simplify the GA using the settings above as a guide

3. File > Save as > Save as type > SolidWorks Part

a. Geometry to save > Exterior faces > Preserve geometry

references > Save E

4. Import the file into JigSpace. q
O

Guide to exporting SolidWorks files to JigSpace 13



@ Using the performance indicator

When creating a Jig, the performance indicator in the editor displays a read out of your current triangle count and number of meshes (or sub-

objects). Understanding this will help you determine when to optimize or simplify the 3D models in your Jig.

For best results we recommend less than 200,000 triangles (or polygons) and less than 50 sub-objects. Jigs also have an option to

automatically keep your 3D models optimized, which we recommend keeping toggled on.

JigSpace
(@ Object list X
3 ~ @ Electric Scale
@ &) SM_Analytical_Balance_r-_...
& SM_Analytical_Balance_bo...
+ & SM_Analytical_Balance_bo...
@ SM_Analytical_Balanc... ®
G & Cylinder.057_Cylinder.080
% 1 Biasatoty Guiblhot (3 Jig performance optimisation X
& Safehood.001_Mesh.009
@ Safehood_Mesh.010 Optimizing your Jig will improve the loading time and performance boost
on all viewing devices.
> @ vials
T Lab configuration option: ... 7K ‘ Z +1‘29X
Replace model with your own ... Triangle count (2 Sub-object count  (®) Performance boost
B -
S Quick!
> @ Electric Scale c Keep 3D models optimized |
q &
]
O £
@ E
o Y @robotarm
@ & Object.016_Mesh.024
coe @ Object.015_Mesh.023
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https://www.jig.space/help-center/performance-indicator

JigSpace has given a whole new usage
for already available assets - our
engineering solid models. These are
only available for the technology group
within the organization, and the
equipment end-users were often
relying on 2D drawings to learn about
our tools.

The level of detail, views and ability to
interact with a Jig, has helped our
team to better understand our
technologies.

Tarcisio Antunes
Product Champion, Cementing
Halliburton

It's highly valuable in my line of work
to be able to quickly and easily
visualise - in 1:1 scale - CAD models
that I'm working on.

These tools are essential to making
that happen.

Kaitlyn Lee
Industrial Designer
DTCo
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The
Design

Technology
(o1,

About DTCo

This guide was prepared in collaboration with Design Technology
Company (DTCo).

DTCo provides a low risk, easy to engage, scalability option for
mechanical design teams. Our literacy with design technologies makes
us an essential part of any engineering project. With over 20
mechanical designers have deep Computer Aided Design experience
that is enhanced by a team with a broad understanding of the currently
available design technologies. These include laser scanning,
photogrammetry, cloud based collaboration for CAD, virtual reality (VR)
and augmented reality (AR).

Learn more: www.designtechco.com.au

J9

Jo

About JigSpace

JigSpace enables teams with big ideas to create and share stunning 3D
presentations and augmented reality experiences - we call them “Jigs” -
in seconds They can be viewed on any device, from mobile to web
browsers to the Apple Vision Pro.

Create a free account to try for your self.
Showcase what makes your product unique, go deep with step-by-step

instructions, and make it engaging fraining simulations in augmented

reality.

Learn more: www.jig.com
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